0
$\begingroup$

Is there a workaround for the following bug in version 12.0.0. This is in MacOSX.

g = Graphics3D[{}, ImageSize -> {1000, Automatic}, Boxed -> False,       ViewPoint -> 10^3 {1, 1.45, .5}, Method -> {"ShrinkWrap" -> True}];
g = Show[g, Graphics3D[{Red, Opacity[.5], Polygon[{{0, 0, 0}, {1, 0, 0}, {1, 1, 0}, {0, 1, 0}}]}]];
Magnify[g, .5]

Output: enter image description here

$\endgroup$
  • $\begingroup$ works fine on Mathematica 12 / Ubuntu 18.4. Maybe try the option "ImageSize -> 500" inside Show[...] instead of Magnify. $\endgroup$ – banone Jan 31 at 9:14
  • $\begingroup$ I cannot reproduce this on macOS 10.14 with Mathematica 12.0.0 and a Radeon Pro 560 GPU $\endgroup$ – Szabolcs Jan 31 at 10:35
  • $\begingroup$ What if you go to your Option Inspector, change Scope to Global Preferences, and change the value for Graphics Options -> Rendering Options -> 3D Rendering Engine to some of the other values? Do any of those help? $\endgroup$ – ktm Jan 31 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.