7
$\begingroup$

Bug introduced in 12.0


I have defined the settings of a new remote kernel from Kernel Configuration Options in a MacOS machine. But the specification have a mistake and I need to redefine. When I try the new specifications do not get saved and upon opening Mathematica again it all stays as it was.

I wonder whether there a file somewhere on my home directory where this info is stored so that I can manually remove and start afresh.

$\endgroup$
3
  • $\begingroup$ Possibly init.m (for instance FindFile["init.m"] or reference.wolfram.com/language/ref/file/init.m.html). $\endgroup$
    – Michael E2
    Commented Jan 30, 2020 at 14:52
  • $\begingroup$ @MichaelE2 That would find the kernel init.m, but she need the FE init.m for this. $\endgroup$
    – Szabolcs
    Commented Jan 30, 2020 at 15:21
  • $\begingroup$ @Szabolcs That's why I included the link. Well, that and I didn't know whether it was an FE or a kernel problem. $\endgroup$
    – Michael E2
    Commented Jan 30, 2020 at 16:16

1 Answer 1

5
$\begingroup$

This is a major bug in version 12.0.0. Frankly, I am puzzled by why they didn't release a 12.0.1 to fix this ... for me it is a recurring major inconvenience.

The file in which the settings are stored can be found in this directory:

SystemOpen@FileNameJoin@{$UserBaseDirectory, "FrontEnd"}

Close Mathematica before editing it. First try init.m. If it contains only SetOptions[$FrontEnd, "VersionedPreferences"->True] and nothing else, then you have version-specific preferences enabled and you must edit 12.0_init.m instead.

Look for the EvaluatorNames option and make sure you don't break the syntax (i.e. fail to close braces, etc.)

I suggest you correct the specification directly in init.m instead of removing it and trying to re-create it with the GUI. Otherwise you may soon run into the same problem.

$\endgroup$
1
  • 1
    $\begingroup$ Thanks a lot !!! I have been literally wasting days on this!!! (editing the file with 11.3 and trying to run it on 12.0) $\endgroup$
    – chris
    Commented Apr 28, 2020 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.