-1
$\begingroup$

enter image description here

Plot[x, {x, 0, 5}, Frame -> False, FrameTicks -> None,  FrameStyle -> Directive[Red, Dotted]]

I also tried FrameTicks none, and it doesn't seem to be working either, but that is exactly how it works on the examples page, what could this be caused by?

At first I thought, it was my Installation that was somehow not working but, for example

Plot[Sin[x], {x, 0, 10}, Frame -> {{False, True}, {False, False}}]

Works while

Plot[Sin[x], {x, 0, 10}, Frame -> {{False, False}, {False, False}}]

Will not work..

$\endgroup$
  • 4
    $\begingroup$ That plot has Axes and Ticks, but it does not have a Frame and FrameTicks. Use the Axes and Ticks options (see also Graphics documentation, as well as the example on the Plot documentation page). $\endgroup$ – Szabolcs Jan 20 at 12:26
  • $\begingroup$ Thanks, this solved my question $\endgroup$ – Rainb Jan 20 at 14:22
2
$\begingroup$

When you have a Plot, and you put a nonempty frame value, this will override the Axes parameter, which is why the example didn't work. This can be done with

Plot[x, {x, 0, 5}, Axes -> False, Ticks -> None]

Instead. the now right plot

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.