2
$\begingroup$

I'm new to Mathematica. I wrote the following code and got the output as follows Euler

I cannot reproduce the code here as I don't know how to type 'e' in the blackboard font. I typed it in Mathematica by using the Esc key.

The problem is that in my input code, I've got an upright 'e' while in the plot legends, I've got an italic 'e'. Why does this happen and how to get an upright 'e' in the legend as well? I'm using Mathematica 12.0.0.0.

$\endgroup$
  • 4
    $\begingroup$ Try StandardForm["\[ExponentialE]"] in your plot legend instead of "e". $\endgroup$ – MarcoB Jan 13 at 19:04
  • 1
    $\begingroup$ Quick (and perhaps uncorrelated) tip : Check from your notebook toolbar Palettes>Basic Math Assistant> Typesetting. You can find all symbols under the second column $\infty \beta$ and their keyboard shorcuts. $\endgroup$ – Sumit Jan 14 at 8:52
3
$\begingroup$

The reason for this is that Mathematica use default options for plotting and labeling your graphics. On the case of plotting legends, by default Mathematica tries to print expressions in TraditionalForm. All this options can be customized. You can use StandardForm as follows:

Plot[\[EscapeKey]ee \[EscapeKey], {x, -5, 5},
 PlotLegends -> {StandardForm["\[EscapeKey]ee \[EscapeKey]]"]}]
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.