3
$\begingroup$

As I was trying to save my notebook by hitting ctrl + s, I might have hit a different letter by accident and something unexpected happened:

An extra row appeared below the menus at the top:

enter image description here

and the check-mark seems to now permanently be set in:

Window -> Toolbar -> Formatting

(I tried clicking on it several times, but this check-mark never goes away.)

Worst of all, when creating a new cell, the cell now defaults to a Text cell instead of an input cell.

What happened here? Is there some way to revert my notebook to its original standard behavior?

EDIT:

Following suggestions in the answers, the EditBar is now gone, but all my calculation cells are still indented inward, while text cells are not indented, and creating a new cell also still defaults to a text cell instead of input. Any idea how to fix that?

Also, In: and Out: labels at the left are now grey and turn orange upon evaluation for some reason. This color scheme was not present before...

$\endgroup$
5
$\begingroup$

Another possibility is to use CurrentValue:

CurrentValue[EvaluationNotebook[], WindowToolbars] = Inherited

{}

$\endgroup$
  • $\begingroup$ Thank you! Perhaps you also know how to make creating a new cell default to Input cell instead of text cell? (See my edit in the question.) $\endgroup$ – Kagaratsch Nov 21 at 6:17
  • $\begingroup$ @Kagaratsch Are you sure you didn't change the stylesheet? What happens if you switch to the Default stylesheet? $\endgroup$ – Carl Woll Nov 21 at 6:21
  • $\begingroup$ Thank you for pointing out stylesheets! I looked it up and changing it back to Default made my notebook normal again. I don't know how it happened, maybe ctrl+s means 'change stylesheet' when Australian keyboard layout is selected? $\endgroup$ – Kagaratsch Nov 21 at 6:32
3
$\begingroup$

I would open the Option inspector, make sure that global preferences are selected, then navigate Notebook options → Display options.

You should be able to deselect the EditBar from Windows toolbars to solve your problem.

$\endgroup$
  • $\begingroup$ Thank you, the EditBar is now gone, but all my calculation cells are still indented inward, while text cells are not indented, and creating a new cell also still defaults to a text cell instead of input. Any idea how to fix that? $\endgroup$ – Kagaratsch Nov 21 at 6:13
  • 1
    $\begingroup$ @Kagaratsch, on my installation, the menu entry Format → Style has "Input" checked. My default cell type is Input. $\endgroup$ – dwa Nov 21 at 6:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.