0
$\begingroup$

I am having a problem with the Mathematica InverseSeries command.

Looking at the information page here, we have the following example;

InverseSeries[x^2 + 3 x^4 + O[x]^8]

With output $\sqrt{x}-\frac{3 x^{3/2}}{2}+\frac{63 x^{5/2}}{8}+O\left(x^{15/2}\right)$. This works fine for me. They then invert this expression again;

InverseSeries[%]

Which outputs $x^2+3 x^4+O(x)^8$, as one would expect. However when I run these commands I simply get;

InverseSeries[x^2+3x^4+O[x]^8]
Sqrt[x]-(3 x^(3/2))/2+(63 x^(5/2))/8+O[x]^(15/2)

InverseSeries[%]
InverseSeries[(x-(3 x^3)/2+(63 x^5)/8)+O[x]^28,x]^2

I don;t have a heap of experience with mathematica, but I have noticed similar behaviour when I have inputted expressions incorrectly. Here thoguh I am literally copy and pasting from the examples webpage.

Any help would be much appreciated, thanks!

$\endgroup$
  • 2
    $\begingroup$ Works fine for me (Windows 10, Mathematica 11.3) - which version are you using? Also, did you try to restart Mathematica to see if it still happens then? $\endgroup$ – Lukas Lang Oct 6 '19 at 12:40
  • $\begingroup$ I saw a similar problem with v12 on a Mac; however, when I quit the kernel and restarted, it worked as expected except that the order was different. That is, I end up with x^2 + 3x^4 + O[x]^7 $\endgroup$ – Bob Hanlon Oct 6 '19 at 22:27
  • $\begingroup$ Im on Windows 10, Mathematica 11.1. I have tried restartign and quitting the kernel. I'm currently downloading version 12.0 to see if that helps. $\endgroup$ – CoffeeCrow Oct 6 '19 at 22:55
0
$\begingroup$

Updating to Mathematica 12.0 fixed this issue.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.