5
$\begingroup$

I see the Streaming package mentioned in this question

How to use Streaming package in v11.1?

with advice on getting it working in V11.1.

I've failed to get either the built-in version or the patch referenced in the question working.

Is this undocumented functionality now abandoned?

I think it matches Mathematica quite well, so I'd been hoping to use it.

EDIT

With a new kernel, I tried

Import["https://raw.githubusercontent.com/lshifr/StreamingPatch/\
master/StreamingPatchBootstrap.m"]

DownloadAndInstallStreamingPatch[]
Get["StreamingPatch`"]

I got the error/warning

TypeSystem`Atom::shdw: Symbol Atom appears in multiple contexts {TypeSystem`,System`}; definitions in context TypeSystem` may shadow or be shadowed by other definitions.

I then tried

ll = Streaming`LazyList`LazyListCreate[Range[100000], Byte[10000]]

and got

Throw::nocatch: Uncaught Throw[$Failed,Streaming`Common`StreamingException[Streaming`LazyList`LazyListCreate,{Streaming`LazyList`Chunking`CreateChunkedData[Streaming`DataStructures`DataTypes`ListIterator`PackagePrivate`IteratorCreate[Streaming`DataStructures`DataTypes`ListIterator,<<3>>,Remove[<<74>>,<<71>>]&],Byte[<<5>>]],<<4>>}]] returned to top level.
$\endgroup$
  • 2
    $\begingroup$ The general question of the status of Streaming is a hard one. I hope that at some point it will be in production in documented form, there seems to be a revived interest in this kind of functionality in the company. But it is hard to say when that happens. One thing I can try doing is to provide some more examples to better illustrate it. Regarding the patch: I just tried the patch on V12.0 and it works for me. What exactly does not work for you? $\endgroup$ – Leonid Shifrin Sep 7 at 21:06
  • $\begingroup$ Looks like Jason B.'s Atom object is fuxing with the TypeSystem paclet. Might work to just try to PacletUpdate that. On the other hand unclear to me why the TypeSystem would be an issue. What's inside the Remove? $\endgroup$ – b3m2a1 Sep 7 at 23:18
  • $\begingroup$ The shadow message is irrelevant (I am getting it too). It looks like the patch doesn't work for you, for some reason. The error you are getting is exactly the one that is there before the patch is applied, and after it is applied, the error is gone for me (12.0 on Mac OS X). What platform are you on? I have created a chat room where we could continue the discussion - we could try debugging the problem. $\endgroup$ – Leonid Shifrin Sep 8 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.