3
$\begingroup$

With a fresh installation of Mathematica on a new raspberry pi 4, I find that the links to help and documentation and the Wolfram site are all erroneously prefaced by "/home/pi" which causes an error since the links are then not found. I tried 3 modes of installation : (i) rpi menu add software (ii) sudo apt-get ... (iii) running the installation shell on the Wolfram rapberrypi site. All gave the same result: succesful installation but this same problem. I would be glad of any fixes (e.g. in Options) or ideas how to correct the installation. Is there some way of seeing what variable it is that contains this information, which is erroneously set to the default installation place for Wolfram-Engine, corrupting network links from http://.. to /home/pi/http://.. ?

$\endgroup$
  • $\begingroup$ All Mathematica does is ask the system to open a URL using the default application registered for handling URLs, which is typically a web browser. Does the following command work xdg-open 'http://www.google.com' ? $\endgroup$ – ilian Aug 18 at 14:14
  • $\begingroup$ Thanks: yes this test also fails in the same way: /home/pi/google.com is the URL looked up, which of course fails. Where can this be corrected? How did it arise on a clean installation? $\endgroup$ – John McC Aug 18 at 21:08
  • $\begingroup$ So this means I guess it is not a Mathematica specific problem ... $\endgroup$ – John McC Aug 18 at 21:12
  • $\begingroup$ This should be configurable -- perhaps try xdg-settings, on my RPi 4 the default-web-browser property is set to chromium-browser.desktop $\endgroup$ – ilian Aug 18 at 21:16
  • 1
    $\begingroup$ I tried xdg-settings as suggested: xdc-settings --list returned only the Default browser and URL manager. Setting the default-web-browser to chromium-browser.desktop produced no change. I then reinstalled xdg-utils with sudo apt-get install --reinstall xdc-utils. Now everything is working at last - no /home/pi/ prefixing either with xdg-open or Mathematica. Thanks ilian for your help on this! $\endgroup$ – John McC Aug 19 at 6:36
3
$\begingroup$

The solution was to reinstall xdg-utils with
sudo apt-get install --reinstall xdg-utils
(many thanks to ilian for linking the problem to xdg-open rather than Mathematica).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.