2
$\begingroup$

Sample data:

Model[x_] = a E^(-k x) + b E^(-j x);
SampleData = {#, Model[#] + RandomVariate[NormalDistribution[0, 0.02]]} & /@ 
    Range[0, 5, 0.01] /. {a -> 1.03, b -> 0.43, k -> 0.96, j -> 3.26};

There is a particular plot style I need to reproduce: open circles (not empty). Here is my attempt within the default stylesheet:

ListPlot[SampleData, PlotRange -> Full, Frame -> True, 
 FrameLabel -> {"Time (s)", "Amplitude"}, 
 LabelStyle -> Directive[Black, 16, Background -> White], 
 Background -> White, 
 PlotMarkers -> 
  Graphics[{White, EdgeForm[Directive[Blue]], 
    Disk[{0, 0}, Offset@3]}], ImageSize -> Automatic -> 500]

(The Background designations are for when the stylesheet changes to something with a non-white background for the output cells.)

enter image description here

This looks right. But when I change to a different stylesheet, for example StandardReport (which I prefer because it makes input vs. output cells extremely obvious), I get the following:

enter image description here

What is going on? And how do I fix it?

$\endgroup$
2
$\begingroup$

Found a workaround. Add PlotStyle->Directive[Background->Transparent]. According to @Kuba (comment below), the default background of markers graphics is gray for this stylesheet. This means that the background for graphics needs to be manually set to Transparent for the behavior to work as expected. Thank you, @Kuba, for the explanation!

$\endgroup$
  • 2
    $\begingroup$ What you see is a stack of background of markers graphics which by default are gray for this stylesheet. The problem is that somehow setting Transparent background there does not work. What works is your solution so you can add my explanation to it for clarity. $\endgroup$ – Kuba Jul 31 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.