fit=Import["/p/a/t/h/", "Table"];
ListContourPlot[fit, MaxPlotPoints->400, ContourStyle->Directive[Black,Dashed], Contours->100, PlotLegends->Automatic, InterpolationOrder->10]

second plot is

relax=Import["/p/a/t/h/", "Table"];
ListContourPlot[relax, PlotLegends -> Automatic, 
 ImageSize -> Large, ScalingFunctions -> {"", "", "Log10"}, 
 Contours -> 50, InterpolationOrder -> 1, 
 PlotRange -> {{1000, 4000}, {0.2, 0.4}, {400, 90000}}]

@mjw As your advice I added the code on the question, thank you.

First plot enter image description here

Second plot enter image description here

The number of the data is 2400 and the fragmented region has the highest z-values. Is that the reason the plot is fragmented?

Any hints for the problem?

The data is on the link (google drive : (first data) https://drive.google.com/open?id=1x-NAD9Vs8wyv9QbDgjcaT9SujHlHChAd and (second data) https://drive.google.com/open?id=1hOTWZKpSzm6SHWJVgv40kMFo_b5xVzZr)

UPDATE: As @mjw 's advice I tried with mesh->None, InterpolationOrder->0 but the resolution of the plot is not good at all. enter image description here

| improve this question | | | | |
  • $\begingroup$ Thank you very much for the link to the data! If you were to input the Mathematica code, rather than show an image, we could better help by starting with your line-of-code. Otherwise, to help you, each person needs to type in the line. $\endgroup$ – mjw Jun 28 '19 at 17:46
  • $\begingroup$ Can somebody please explain the best way to import this data into Mathematica? $\endgroup$ – mjw Jun 28 '19 at 17:51
  • $\begingroup$ @mjw I use this data=Import["/p/a/t/h/", "Table"]; $\endgroup$ – Dong gi Kang Jun 28 '19 at 17:53
  • $\begingroup$ Thank you very much! I was missing the option "Table". $\endgroup$ – mjw Jun 28 '19 at 18:44
  • $\begingroup$ InterpolationOrder -> 0 works. Seems that the data is too disconnected from the other data where there is a dropout. $\endgroup$ – mjw Jun 28 '19 at 18:45

Posting this here because it does not fit in the comments section. Please see the comments below the question for background.

ListPlot3D[data, Mesh -> None, InterpolationOrder -> 0, ImageSize -> Large ]

enter image description here

| improve this answer | | | | |
  • $\begingroup$ I just tried but it still gives low resolution and is there are any method to improve the resolution?? $\endgroup$ – Dong gi Kang Jul 2 '19 at 14:07
  • $\begingroup$ Looks okay on my monitor and on a small "smart" phone. What display are you using? What operating system? Also, suggested in the comments above that you break the data up into smaller rectangles, so that you can zoom in on areas with discontinuities. $\endgroup$ – mjw Jul 7 '19 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.