1
$\begingroup$

I don't own Mathematica, but have a (free) Wolfram Cloud account. I'd like to download all of the files in a given Wolfram Cloud directory to my computer. I've used CloudExport to create downloadable gifs and the like, and I can download files individually by clicking the Download link in the cloud directory, but have not figured out how to download in bulk.

To archive and download, e.g. the directory "Files" I've tried things like

archive=CreateArchive["Files"]
CloudExport[archive, "zip", "Zips/testarchive.zip"]
(* CloudExport doesn't support "zip" *)

and

archive=CreateArchive["Files"]
CloudObject[archive]
(* creates a URL, but one that results in a 404 browser error *)

and other variants, but they all fail to do the job at some point.

Does anybody have a solution for this?

$\endgroup$
3
$\begingroup$

Give this a shot:

Export["asd1.txt", 1];
Export["asd2.txt", 1];
arch=CreateArchive[Directory[], (DeleteFile[#];#)&@CreateFile[]];
CopyFile[arch, Append[CloudObject["test.zip"], Permissions->"Public"]]

Replace Directory[] with your actual directory of interest, of course, and "test.zip" with your target directory.

$\endgroup$
  • $\begingroup$ Yasss! CopyFile to a CloudObject works, but I think it could be simplified to just something like CopyFile[CreateArchive["Files"],CloudObject["test.zip"]], where "Files" is the name of the directory to be archived. $\endgroup$ – brainjam Jun 26 at 0:08
  • $\begingroup$ @brainjam if that works let me know. You'll definitely want the Permissions-><some permission set that is easy for you to access> though. $\endgroup$ – b3m2a1 Jun 26 at 0:09
  • $\begingroup$ The only thing I want to do is download the archive, which I can do from within Wolfram Cloud just by clicking on the newly created CloudObject or using the Download option in the directory view. So no permissions required. $\endgroup$ – brainjam Jun 26 at 1:05
  • $\begingroup$ You can also just click on the URL that comes in the output though and it downloads automatically $\endgroup$ – b3m2a1 Jun 26 at 1:21
  • $\begingroup$ Turns out that the value of my $Permissions is Public, which maybe explains why I get away without setting Permissions. $\endgroup$ – brainjam Jun 26 at 1:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.