1
$\begingroup$

I started using Workbench to write documentation again after some time off. Something must have happened (maybe upgrading to v12?), because now when I double click on a documentation page in Workbench to edit it, Mathematica beeps on startup.

Why the Beep? reports

The shared stylesheet "Wolfram/FunctionPageStyles.nb" could not be found. The default stylesheet will be used instead.

I found the required stylesheets available for download here. Where should I put them?

$\endgroup$
  • $\begingroup$ Have you tried the menu File > Install...? $\endgroup$ – Michael E2 Jun 18 at 13:06
  • 1
    $\begingroup$ System stylesheets live in FileNameJoin[{$InstallationDirectory, "SystemFiles", "FrontEnd", "StyleSheets"}] and subdirectories. Local ones should go in FileNameJoin[{$UserBaseDirectory, "SystemFiles", "FrontEnd", "StyleSheets"}]. $\endgroup$ – Michael E2 Jun 18 at 13:13
  • $\begingroup$ @MichaelE2 File > Install... didn't help, but putting them in FileNameJoin[{$InstallationDirectory, "SystemFiles", "FrontEnd", "StyleSheets", "Wolfram"}] manually did. Thanks! $\endgroup$ – Chris K Jun 18 at 13:29
  • $\begingroup$ Are you using the original Wolfram Workbench, or the Eclipse plug-in? I started using the WolframWorkbench (v2 or v3, I don't remember) but that seems deprecated in favor of an Eclipse plugin. Just a thought that if you are using one of the older Workbench versions, you might want to look into the Eclipse plugin. $\endgroup$ – Mark R Jun 18 at 20:41
  • $\begingroup$ @MarkR Thanks, I should have added that I'm using the latest Eclipse plugin. Hasn't been that long of a pause! $\endgroup$ – Chris K Jun 18 at 20:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.