enter image description here

so i tried to install FormCalc on linux and when i run the compile command i get "cannot determine mathematica's system ID using_/usr/local/bin/math"

Has anyone encountered such error and is there a way to fix it ?

  • $\begingroup$ Could you please run: math -run 'Print[$SystemID]; Exit[]' , and show the result? $\endgroup$
    – Wen Chern
    Apr 26 '19 at 17:24
  • $\begingroup$ Does the file /usr/local/bin/math exist and is it executable? $\endgroup$
    – vsht
    Apr 29 '19 at 6:57

I encountered same error. Just notice 3 points :- 1. Check the file/folder permissions of FormCalc. Using ls -la in terminal. 2. Is form is installed or not? Form is required to run FormCalc using Mathematica. 3. Try to run $SystemID command in mathematica. For sure output comes like Linux_ something. It is fine. Otherwise install Mathematica again.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.