6
$\begingroup$

Bug introduced in 11.3 or earlier and persisting through 12.0

Report to WRI [CASE:4246236]


This is using 11.3 on windows 10.

This is a pde from Handbook of first order partial differential equations by Polyanin, Zaitsev, Moussiaux

enter image description here

Mathematica 11.3 returns 1/0 immediately on it.

From a clean kernel

pde = b*(a*(a^2*x^2 + b^2*y^2 - 1)*x + b*y)*D[w[x, y, z], x] + 
    a*(b*(a^2*x^2 + b^2*y^2 - 1)*y - a*x)*D[w[x, y, z], y] + 
    2*a*b*z*D[w[x, y, z], z] == 0;

DSolve[pde, w[x, y, z], {x, y, z}]

Mathematica graphics

Why is 1/0 generated? Is this a bug?

I do not have access to 12.0, I wonder if this same error is generated in 12.0?

$\endgroup$
  • 5
    $\begingroup$ Same result in the cloud (which is running 12.0). Looking at the stack trace, it seems that it is running into the 1/0 while transforming the equation (it generates a fraction of the form $\frac{\cdots}{z\partial_z f(x,y)}$, which is obviously problematic $\endgroup$ – Lukas Lang Apr 15 at 8:14
  • 2
    $\begingroup$ @LukasLang thanks for confirming. I just reported it to WRI and got case number. $\endgroup$ – Nasser Apr 15 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.