2
$\begingroup$

This morning, I opened a document I worked on last week, and all the lines of text that had Control-9 functions in them where the function involved a power written by typing Control-6 were completely mangled. They were either just huge cells of white space, or huge mainly white cells with the odd symbol thrown in with line-breaks in the middle of partially-displayed functions. The document was fine when I closed it yesterday.

Today, even a completely new document displays the same problem. I start a new text cell, type (say) "Text ", then Control-9 to switch to input mode, type s[x], hit Control-6 to raise s to a power... And the text cell suddenly exhibits the behaviour described above. The document is instantly unusable.

In the pictures below, all I did was type Control-6 at the end of the function:

enter image description here

enter image description here

What's going on, and how do I fix it?

UPDATE:

  1. MacOS, fully up to date.

  2. Quitting and restarting Mathematica doesn't solve it. Neither does restarting the computer.

  3. Changing text colour (sometimes) amplifies the problem - adding acres of blank space and making text that was visible disappear.

$\endgroup$
1
$\begingroup$

Bizarrely, after leaving the computer off overnight, the problem seems to have disappeared. I had of course tried restarting the computer before. I'm only posting this for completeness if anyone else encounters the problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.