1
$\begingroup$

I'm trying to train a neural network on Mathematica 11.3, but NetTrain won't work and gives the follwoing error:

"The function "WL_MXGetVersion" was not loaded from the file 
"/usr/local/Wolfram/Mathematica/11.3/SystemFiles/Components/MXNetLink/LibraryResources/Linux-x86-64/MXNetLink.so"

(see attached picture). What can I do to fix this?

enter image description here

$\endgroup$
  • $\begingroup$ Have you restarted Mathematica? Has it ever worked for you? Does it work for the simplest example in the NetTrain documentation? The common solution to this kind of thing is to try to reinstall Mathematica... $\endgroup$ – Carl Lange Jan 16 at 20:09
  • $\begingroup$ @CarlLange Yes, I restarted and tried a fresh installation of Mathematica. $\endgroup$ – nonreligious Jan 16 at 21:30
  • $\begingroup$ Has it ever worked for you? It seems like the issue might be your specific install of Linux, in which case I'd recommend talking to Wolfram support... $\endgroup$ – Carl Lange Jan 16 at 21:40
  • $\begingroup$ No, it hasn't, and I recently updated to a newer version of Mathematica as well. I'll get in touch and see what happens $\endgroup$ – nonreligious Jan 17 at 0:50
1
$\begingroup$

This is not a complete answer, but a fix if someone else has the same problem.

I am running Ubuntu on a machine with a discrete graphics card (Nvidia GTX G-1050) and had disabled this GPU to save power and reduce noise. The above problem occurs when my machine is running in this mode - for some reason, even saying TargetDevice -> "CPU" does not allow NetTrain to work.

Enabling the Nvidia GPU (by doing sudo prime-select nvidia and rebooting) fixes this issue.

I have no idea why this happens, and will post separately regarding this.

$\endgroup$
  • $\begingroup$ That seems like a bug, I suppose you should probably mention it to Wolfram Support. I suppose maybe the neural net stuff sees that you have drivers for that graphics card installed and tried to set it up, but fails because the card exists but isn't enabled, which seems like an easy-to-miss edge case. $\endgroup$ – Carl Lange Jan 30 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.