16
$\begingroup$

I've tried installing Mathematica 11 on Fedora 29 using the .sh install file. The installation seems to have worked (no errors and everything looks normal). However, when I attempt to run Mathematica I get the following error

/usr/local/Wolfram/Mathematica/11.3/SystemFiles/FrontEnd/Binaries/Linux-x86-64/Mathematica: symbol lookup error: /lib64/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var

Seems to be some sort of font error, but I don't know how to fix it.

$\endgroup$
21
$\begingroup$

I had same problem on different Linux. I will show what I did.

This is a known issue. see https://bugs.archlinux.org/task/57948

Problems with fontconfig and Mathematica. The following error is reported. /usr/local/Wolfram/Mathematica/11.2/SystemFiles/FrontEnd/Binaries/Linux-x86-64/Mathematica: symbol lookup error: /usr/lib/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var

What I did is this: become root, and removed 3 libs related to this error, from inside Mathematica system folder. To be safe, you can rename them instead.

Remove or rename freetype.so. and I remember also removing libz.so.

Here is the main link I used to help with this.

https://forums.gentoo.org/viewtopic-p-8198000.html?sid=ab27c1ca8e1927691858595185e18284

I switched back to windows for desktop since then.

I did send bug report to WRI on this. CASE:4082638 This is the reply I got

This may be related to a known issue and the developers are working on resolving it for a future Mathematica version. In the meantime, please consider placing libfreetype.so.6 in the MathematicaInstallationDirectory/SystemFiles/Libraries/Linux-x86-64/ directory. The libfreetype.so.6 component is available at https://wolfr.am/vO0qvWH7PW: Another option is reverting back to fontconfig 2.12. Please let us know if neither option resolves the behavior. Wolfram Technical Supportsupport.wolfram.com

btw, I did not follow the instructions in the email above, since by the time I got the reply, the problem was resolved by deleting these libraries mentioned above.

$\endgroup$
9
  • 4
    $\begingroup$ Thanks you. I had previously tried renaming libfreetype.so and libfreetype.so.6, which didn't help. But now I also renamed libz.so.1, and that seems to have resolved the problem. $\endgroup$ – theQman Jan 12 '19 at 16:47
  • 2
    $\begingroup$ As answer above suggests I copied from /usr/lib/** libz.so.1 and libfreetype.so.6 to MathematicaInstallationDirectory/SystemFiles/Libraries/Linux-x86-64/ and it started working. $\endgroup$ – Oleg Kmechak Apr 23 '19 at 16:23
  • $\begingroup$ Thanks now mathematica start, but adding a subchapter leads to an error/wrong formating. ;-( $\endgroup$ – JoKalliauer May 5 '20 at 8:51
  • $\begingroup$ @JoKalliauer Sorry, I do not understand what you mean by adding a subchapter leads to an error/wrong formating If you mean you were above to start Mathematica now OK, but you have an issue using afterwords, then I would suggest making a new question on that. Myself do not use Mathematica on Linux. But on windows now. $\endgroup$ – Nasser May 5 '20 at 8:55
  • $\begingroup$ This is a very helpful answer indeed +1, but the short-link you provided for the library appears to be broken $\endgroup$ – mattiav27 Sep 5 '20 at 18:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.