2
$\begingroup$

I am trying to produce some publication quality graphics with Mathematica 11.3 on Windows 10 using two NVIDIA GTX970 cards.

I have set Antialiasing to Highest Quality in the Preferences dialog.

This produced no human-observable difference between the quality using Antialiasing->True and Antialiasing->False on a 4K monitor.

My questions are:

  • Does Mathematica reserve CUDA capable GPU cards for CUDA code (even when CUDA is not used) or can it use the graphics cards for Antialiasing?
  • If Mathematica can use graphics cards for graphics, what are the Graphics3D directives and Mathematica settings to enable Antialiasing?
  • Are there any third-party books that discuss creating publication-quality graphics in Mathematica?

I have gone through a number of postings and the most promising solution involves exporting the image to a format that can be rendered in Blender.

$\endgroup$
  • 1
    $\begingroup$ Parallel Kernels have nothing to do with the display of graphics, they can only be used for certain computational tasks. Also, what type of graphics do you need? 2D or 3D? $\endgroup$ – Lukas Lang Dec 30 '18 at 18:16
  • $\begingroup$ Hi Lukas - this may answer the question. I am trying to produce a high-quality 3D graphic. I began wondering if my two NVIDIA GTX970 cards (often used for CUDA calculations) would be used to improve the quality of the rendering when Antialiasing is enabled and set to Highest Quality. There is probably a configuration that will allow Antialiasing to work. In my case, I have not found it yet. $\endgroup$ – Doug Kimzey Dec 31 '18 at 16:36
  • $\begingroup$ I have edited the question for clarity. $\endgroup$ – Doug Kimzey Dec 31 '18 at 17:06
5
$\begingroup$

You may use the RenderingOptions option of Style.

The computer used for the images below does not have a dedicated graphics card but the differences are still noticeable.

No Antialiasing

Style[
 Graphics3D[Sphere[], ViewPoint -> Front],
 RenderingOptions -> {
   "3DRenderingEngine" -> "Mesa",
   "HardwareAntialiasingQuality" -> 0}
 ]

Mathematica graphics

Max Direct3D Hardware Antialiasing

Style[
 Graphics3D[Sphere[], ViewPoint -> Front],
 RenderingOptions -> {
   "3DRenderingEngine" -> "Direct3D",
   "HardwareAntialiasingQuality" -> 1}
 ]

Mathematica graphics

Hope this helps.

$\endgroup$
  • $\begingroup$ Thank you for the reply. The code above did not produce the same improvement on my computer. I am wondering if this is an issue with the dual NVIDIA GTX970 cards that I am using. I will try this on another machine. I will dig into the Style directive further. $\endgroup$ – Doug Kimzey Jan 1 at 13:05
  • $\begingroup$ @DougKimzey Check the settings of the rendering engine that you are using. Is it set to use your graphics card as the default? There is at least one other rendering engine supported in 11.3, check the documentation. 🤓 $\endgroup$ – Edmund Jan 2 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.