3
$\begingroup$

Are there options in Graphics3D that would allow me to set the face color of a Hexahedron to None or make the faces transparent?

I did try FaceForm. But this may not work with Graphics3D primitives (or I am using it incorrectly).

I have the following code:

hexCoordinates = {{-12.5, -10,-6},{-12.5,10,6},{12.5,10,6},12.5,-10,6},{-6.5,-4,0}, {-6.5,4,0},{6.5,4,0},{6.5,-4,0}};

hexShape := Hexahedron[hexCoordinates];

Graphics3D[hexShape, Axes->True, FaceGrids->All, ImageSize->Full, Lighting->{{"Ambient",None}}]
$\endgroup$
  • $\begingroup$ Quit the kernel and run the code from this question. Then fix the code and update the question. Also, what did you try with FaceForm? It seems to work: Graphics3D[{FaceForm@None, Hexahedron[]}]. $\endgroup$ – Kuba Dec 11 '18 at 13:30
  • $\begingroup$ Thanks for the catch. I tried FaceForm[] in the options list but received an error: "An improperly formatted option was encountered while reading a Graphics". $\endgroup$ – Doug Kimzey Dec 11 '18 at 14:17
5
$\begingroup$

I gues the solution is FaceForm[].

Graphics3D[{
  {Ball[{1, 1, 1}/2, 1/5]},
  {FaceForm[], EdgeForm[{Thick, Blue}], Hexahedron[]}
  },
  FaceGrids -> All,
  Axes -> True,
  Boxed -> False
]

boxWithFaceGrids

$\endgroup$
  • $\begingroup$ This works if you don't need FaceGrids->All. It looks like FaceForm[] causes FaceGrids and Axes to be ignored. I am wondering if there is a way to have FaceForms[] with Axes->True and FaceGrids->All. $\endgroup$ – Doug Kimzey Dec 11 '18 at 14:28
  • $\begingroup$ @DougKimzey I don't get interference between the FaceGrids and FaceForm directives: i.stack.imgur.com/8Cdv0.png $\endgroup$ – Jason B. Dec 11 '18 at 14:41
  • $\begingroup$ @DougKimzey are you sure you are following syntax from documentation? E.g. how did you end up with FaceForm in options in the first place. Now, what is the code you are descirbing above? $\endgroup$ – Kuba Dec 11 '18 at 14:43
  • $\begingroup$ If I use: Graphics3D[hexShape, FaceForm[], Axes->True, FaceGrids->All], the axes and grids appear but the hexahedron is solid. An error message appears: "An improperly formatted option was encountered..." If I use Graphics3D[{{hexShape, FaceForm[], Axes->True, FaceGrids->All}}] FaceForm, Axes and FaceGrids are ignored. $\endgroup$ – Doug Kimzey Dec 11 '18 at 14:47
  • 1
    $\begingroup$ @DougKimzey yes. take a look at graphics3d docs. Options should be outside of {}. $\endgroup$ – Kuba Dec 11 '18 at 14:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.