1
$\begingroup$

Edit: I figured out I can use Rescale to retrieve the plot as well as get the correct plot legend. I still can't figure out how to rescale the axes from 10^-9 to 1 though...

enter image description here

Original

I'm trying to make a density plot of a 2D potential energy, but mathematica fails to produce the plots. The system is of relevance for nano-technology so everything is in nano scale, I believe this is the source of my problems.

My code looks like

cont = DensityPlot[(c1 + c2 q^2) (1 - Cos[2 Pi (x - c4 q)/a]) + (c5 + c6 q^2) 
  (1 - Cos[c7 2 Pi (x)/a]) + c3 q^4, {x, 0, 3*^-9},{q, 0, 1.5*^-10}, 
  PlotPoints -> 200, FrameLabel -> {"x[t]", "q[t]"},
  ImageSize -> 400, PlotLegends -> Automatic, ScalingFunctions -> 
  {{1*^-9 # &, 1*^9 # &}, {1*^-9 # &, 1*^9 # &}, # &}]

it results in something that looks like this

enter image description here

there are two issues with this image:

  1. It has been flatly colored blue, however, the the PlotLegend seems to have picked up the right values (edit: this is solved now, see top)
  2. The axes have not been rescaled by 10^9

I would also like to rescale the potential itself by a factor 10^18, to have values around 1, but I couldn't figure out how to do that, so that's not in the code above.

Any ideas what could have gone wrong and how to fix any of those issues?

For reference, here's the parameter values:

c11 = 4.0*^-20;
c22 = 3.0;

c1 = c11;
c2 = c22;
c3 = 14*^20; 
c4 = 7.0; 
c5 = 0.5 c11; 
c6 = 0.5 c22; 
c7 = 1.0; 

The density plot looks fine if I scale all constants by some large number. But then the rescaling still doesn't work...

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.