0
$\begingroup$

I have Mathematica 11.0.0 installed on Windows 10, with an NVIDIA GT 630M GPU on my Dell Inspiron.

I am trying to run the CUDA examples in the Help files. All of the setup functions for CUDALink work fine. For example:

CUDAQ[]

True

CUDADriverVersion[]

369.09

CUDAResourcesInformation[]
{{"Name" -> "CUDAResources", "Version" -> "10.5.0", 
   "BuildNumber" -> "", "Qualifier" -> "Win64", 
   "WolframVersion" -> "10.5+", "SystemID" -> {"Windows-x86-64"}, 
   "Description" -> "{ToolkitVersion -> 7.0, MinimumDriver -> 300.0}", 
   "Category" -> "", "Creator" -> "", "Publisher" -> "", 
   "Support" -> "", "Internal" -> False, 
   "Location" -> 
   "C:\\Users\\DELL\\AppData\\Roaming\\Mathematica\\Paclets\\\
    Repository\\CUDAResources-Win64-10.5.0", "Context" -> {}, 
   "Enabled" -> True, "Loading" -> Manual, 
   "Hash" -> "79fa747a52a45bf2d78e2c3516c80061"}}

However when I run the examples of CUDA functions in the documentation I get the following error:

CUDADot[{1, 2, 3}, {4, 5, 6}]

CUDAQ::internal: CUDALink experienced an internal error.

Could anyone tell me how can I fix this?

Addtional Information on CUDA C Compiler

If I try the CUDACCompiers[] command the following is the result

CUDACCompilers[]

{{}}

Although I have Visual Studio 2010 Express installed on the system. Is this the cause of the problem? It is evident that CUDALink is not recognizing the C Compiler. How do I correct it?

Also, ALL CUDA functions are not working, not just CUDADot.

$\endgroup$
  • $\begingroup$ Is CUDADot the only thing that fails, or do all CUDA* functions? That's important info. $\endgroup$ – user6014 Dec 1 '18 at 0:02
  • $\begingroup$ FWIW my CUDA driver is 388.13 and it works. Maybe you should try to update? $\endgroup$ – user6014 Dec 1 '18 at 0:09
  • $\begingroup$ CUDALink also does not recognize my C compiler. Could that be a problem? Also, I tried installed CUDA toolkit 10 from NVIDIA, it says that there is no supported Visual Studio version on the system (mine is Visual Studio 2010 Express). It says that some components of CUDA will not work properly. Should I install anyways? $\endgroup$ – Iconoclast Dec 1 '18 at 9:31
  • $\begingroup$ @ at your first comment. yes all CUDA* functions fail. $\endgroup$ – Iconoclast Dec 1 '18 at 9:52
  • 1
    $\begingroup$ @user6014 Yes updating the display drivers solves the problem. I now have 391.x for my GPU. But still I can't seem to get CUDALink recognize Visual Studio C++ 2010 Express compiler. $\endgroup$ – Iconoclast Dec 1 '18 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.