1
$\begingroup$

I just migrated my Mac from one machine to a new one and it seems like MATLink is broken now. When I call OpenMATLAB[] in Mathematica the command hangs forever.

I ran engine.sh, as instructed in the troubleshooting, but do not get any library errors (it just says Create Link :).

I tried reinstalling matlab and redownloaded MATlink.

MATLink`Developer`GetInfo[] Output:

MATLink 1.1 for MacOSX (Fri 15 Aug 2014)

11.3.0 for Mac OS X x86 (64-bit) (March 7, 2018)

csh:
/bin/csh

MATLAB:
/Applications/MATLAB_R2014a.app
/Applications/MATLAB_R2017a.app
/Applications/MATLAB_R2018b.app
$\endgroup$
  • $\begingroup$ 1. Did you try restarting Mathematica completely? 2. Does MATLAB work when started separately? 3. Can you try running ConnectEngine[] after loading MATLink? Does it hang? If not, try OpenMATLAB[] now. 4. When you evaluate OpenMATLAB[], do you notice a MATLAB icon bounding in the dock? $\endgroup$ – Szabolcs Nov 8 '18 at 15:13
  • $\begingroup$ 1. yes 2. Yes. 3. Hangs as well 4. No icon $\endgroup$ – MaxJ Nov 8 '18 at 15:17
  • $\begingroup$ This is going to take some back and forth. Please join this chatroom and continue there: chat.stackexchange.com/rooms/85499/matlink $\endgroup$ – Szabolcs Nov 8 '18 at 16:26
  • $\begingroup$ I have not heard back from you. Did you resolve this already and can we close the question? $\endgroup$ – Szabolcs Nov 9 '18 at 13:39
  • $\begingroup$ I commented back. Your solution works but how can I implement it? $\endgroup$ – MaxJ Nov 9 '18 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.