2
$\begingroup$

"Input" cell style automatically inserts a space after each comma, with natural exceptions such as when quotation marks are open.

"Code" cell style does not.

After looking through all the style definitions and using the options inspector, I cannot see how this behaviour is controlled.

I would like "Code" cells to behave like "Input" cells with respect to comma handling; how can I achieve this?

$\endgroup$
4
$\begingroup$

The setting you are looking for is AutoSpacing -> True.

And you need to set it on a stylesheet level for "Code" cells or on a Cell level in a notebook (which does not make sense for .m files).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.