I have two win 10 computers and I have enabled the built-in windows 10 OpenSSH Client and OpenSSH serve in both of them. I can use one of the computers to run programs on another computer. I have also set up the remote kernel through "kernel configuration options" and I can use the remote kernel from the local front-end.

Now I am trying to do parallel computing. I need to launch a remote kernel. According to the help documentation, I tried the command like this:

  "ssh username@host \"D:\\Program Files\\Wolfram Research\\Mathematica\\11.3\\MathKernel -mathlink -linkmode Connect `4` -linkname `2`\"", 1]]

When I run this command a blank CMD window was popped up. I waited for a while and nothing happened (strictly speaking a Wolfram kernel process was in high CPU usage). So I closed the CMD window, and some error messages appeared:

LaunchRemote::time: Operation Run timed out after 15.` seconds.

LinkObject::linkn: Argument LinkObject[[email protected], [email protected], 225, 10] in LinkConnectedQ[LinkObject[[email protected], [email protected], 225, 10]] has an invalid LinkObject number; the link may be closed.

I googled for a long time and didn't find a solution. Can anyone help me?


1 Answer 1


Finally, I've found a way to launch remote kernal in win10 like this:

  "bash -c \"ssh -f Administrator@`1` E:/M/math -wstp -linkmode Connect `4` -linkname `2` -subkernel -noinit\"", 1]]

Those parameters, "","Administrator" and "E:/M/math", need to be replaced.

To use this code one need to install the Windows Subsystem for Linux(I use this Guide), and sets the ssh login without password from the subsystem to remote PC.

To launch n kernels one can use "Do[..,n]" to repeat the code above.

Why one cannot launch remote kernels by directly using CMD command shell seems that CMD cannot run background nor generate a return. This may cause the launch time out.

  • $\begingroup$ Good luck with connection resumability and dynamics! $\endgroup$
    – M.R.
    Commented Jan 20, 2020 at 2:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.