I'm running Mathematica 9.0.0 on a Macbook Air with OSX 10.6.8 and I've recently started having issues with the font in the program. All special characters are being replaced with other characters in the INPUT and OUTPUT cells. So for example I would type "[ ]" and in Mathematica it would show as "@ D". Also a "LikeResource|c|58" error appears during each startup. Here are a few other examples of where the font is being switched:

Other examples:

"[ ]" ----> "@ D"

"{ }" ----> "8 ?"

"( )" ----> "H L"

"{9}" ----> ";9?"

This doesn't affect the processing of Mathematica at all but it makes it Very difficult to use and read other peoples notebooks. I've already tried clearing the BaseDirectory and reinstalling the program and even looking through FontBook to ensure none of the fonts are corrupted or duplicated. Can anyone help me out with this issue, thanks for any help you can provide!

  • $\begingroup$ Anything in the Console? $\endgroup$ – cormullion Jan 23 '13 at 14:01
  • $\begingroup$ This has happened to me exactly once (on 10.6.x too, if I remember right) and restarting Mathematica fixed it for me. I could never get it to happen again (and didn't take screenshots), so didn't think it was worth emailing support. It has never happened in 10.7.x and 10.8.x, so you might consider updating... $\endgroup$ – rm -rf Jan 23 '13 at 14:40
  • $\begingroup$ Did you see this? $\endgroup$ – VLC Jan 23 '13 at 15:35
  • $\begingroup$ I have looked at that exact link, unfortunately with no luck. I followed all the steps and no fix.. $\endgroup$ – Cyrus Jan 23 '13 at 16:05
  • $\begingroup$ @Cyrus, I had a 'similar'issue Link and basically had installed the latest version etc. At the end I removed all mathematica files that I could find and reinstalled again with succes. $\endgroup$ – Lou Jan 23 '13 at 16:57

I experienced the same error today, and solved it by following the instructions in the link that @VLC posted. I validated my Fonts, reinstalled Mathematica, and started the app with clean prefs. None of those steps solved the problem on their own, but after a restart everything was back to normal. So, possibly not all of the steps were required.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.