6
$\begingroup$

At the moment we only have access to version 8 of the Lightweight Grid (i.e. version 8 of the Mathematica kernel). Is it safe to run version 8 subkernels together with a version 9 main kernel? It does appear to work, but I am not sure if things can go wrong in unexpected ways.

(For safety I use a v8 main kernel for these calculations, but I since everything seems to work with a v9 main kernel as well, I was curious if this is actually supported.)

$\endgroup$
7
$\begingroup$

This is supported, and should work. You should of course be aware of the version differences, i.e. language feature differences, when writing code (e.g. don't do ParallelEvaluate of new-in-9 functions on V8 subkernels). But the control channel plumbing, from MathLink up to the parallel tools, should work. Lightweight Grid itself is quite flexible this way, you can create separate services for launching V7, V8 and V9 kernels.

You will also be able to launch V6 kernels but they will of course not have the integrated parallel tools built into Version 7. You might even be able to launch a V5.2 kernel. That's as far back as I go :)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.