2
$\begingroup$

I have an install of Mathematica 11.2 that worked without problems until now, but now, after not using it for a few months, it does not start up (hanging on "Initialising kernels...").

I tried to start WolframKernel and wolfram from the terminal, which immediately give a seg fault.

I also renamed the mathematica folders as described here here, but the only effect that had was that it hung on "Initialising preferences... " instead.

I am running Kubuntu 17.10.

I am not sure what I can try next, so any ideas would be appreciated.

$\endgroup$
  • $\begingroup$ 1. Rename the ~/.Mathematica directory (to back it up and remove it in one step). 2. Create a new ~/.Mathematica directory and copy back the old Licensing directory that was found within. 3. Try if it works now. $\endgroup$ – Szabolcs Jul 5 '18 at 18:47
  • $\begingroup$ Had already tried that.. Did not work. Reinstalling fixed it though. $\endgroup$ – fifaltra Jul 6 '18 at 7:30
1
$\begingroup$

I reinstalled it and then it worked again. I have no idea why.

$\endgroup$
0
$\begingroup$

Just a guess. From here: http://www.wolfram.com/mathematica/system-requirements.html

they support Ubuntu up to 17.10. No mentioning of the variant Kubuntu.

Perhaps an upgrade of some libraries, I would guess qt or kde, made Mathematica hang. Starting from terminal what messages do you obtain?

I know for sure that the graphical interface of 11.3 doesn't work under Fedora 28 at all. Still works in terminal though.

$\endgroup$
  • $\begingroup$ The easiest way to solve the problem is to reinstall Mathematica $\endgroup$ – Alex Trounev Jul 5 '18 at 15:48
  • $\begingroup$ I reinstalled in the end... Now it works... But maybe it was some problem with a library that was fixed by reinstalling. $\endgroup$ – fifaltra Jul 6 '18 at 7:29
  • $\begingroup$ @fifaltra Please do not accept an answer if it does not solve your problem. This answer says that Kubuntu is not compatible. You yourself seem to imply that you do use Mathematica on Kubuntu, so this claim cannot be true. If you accept the answer, future visitors will read it and conclude that they cannot use Kubuntu. $\endgroup$ – Szabolcs Jul 6 '18 at 7:47
  • $\begingroup$ @Szabolcs, well now i have posted my own answer, which is not really satisfying, but that is what solved the problem $\endgroup$ – fifaltra Jul 10 '18 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.