7
$\begingroup$

This is happening after I upgraded to 11.3. I am on Linux Mint.

Whenever mathematica finishes evaluating the cells in a Notebook, if that Notebook is minimized, it will pop up and steal focus from my other windows. This is very disruptive.

Is anyone experiencing a similar behavior? How can I disable it? I would like the Mathematica Notebook window to remain minimized after it finished the computation. Perhaps it could flash in the taskbar, but stealing focus is definitely too much.

$\endgroup$
  • 1
    $\begingroup$ In the "System Settings / Windows / Behaviour" I have "Window focus mode" set to "Mouse", so that focus remains with which ever window the mouse is over. If I change it to "Click" I see the behaviour you describe. I see there is also an option "Prevent Focus Stealing". That seems to fix it. $\endgroup$ – mikado Jun 30 '18 at 13:01
6
$\begingroup$

In the "System Settings / Windows / Behaviour" I have "Window focus mode" set to "Mouse", so that focus remains with which ever window the mouse is over.

If I change it to "Click" I see the behaviour you describe.

There is also an option "Prevent Focus Stealing", that seems to fix your problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.