2
$\begingroup$

I've trained a NN model by NetTrain with Mathematica 11.3.0, and I can load the model correctly to predict.

My model is saved by .mx format.

After few months, I cann't load the model correctly.

However, it seems my .mx model@11.3.4[maybe] can not load by verion@11.3.5 ,buy my models.mx@11.3.5 can be load by version@11.3.4

My Mathematica Version is always 11.3.0

And I see a Version Number of model————11.3.5, is it related with the problem? I've tried .mx format, wlnet, wmlf format.

enter image description here

enter image description here

$\endgroup$
  • 1
    $\begingroup$ I'd contact support. wolfram.com/support/contact/email/?topic=Technical $\endgroup$ – user6014 Jun 22 '18 at 12:58
  • 4
    $\begingroup$ PacletUpdate["NeuralNetworks"] should move you from 11.3.4 to 11.3.5 I think, though. $\endgroup$ – user6014 Jun 22 '18 at 13:31
  • 1
    $\begingroup$ From the message it would appear that the MX file was saved using a newer version than the one being used to import it. Is that correct? $\endgroup$ – Daniel Lichtblau Jun 22 '18 at 17:57
  • $\begingroup$ @user6014 it works,thanks $\endgroup$ – HyperGroups Jun 23 '18 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.