1
$\begingroup$

I am running Mathematica 9.0.1.0 on a MacBook with OS X El Capitan, version 10.11.6.

I used to have no problems using Mathematica. Then recently, it started to be extremely slow. Even for the simplest calculations (I mean trivial stuff, like 8 times 9). If the calculation is trivial I eventually get the answer but after more than a minute of work, even to find 8x9.

I checked the CPU usage and I see that even when I ask trivial calculations, the MathKernel process shoots up above 99% of CPU usage. I also noticed that if I abort the calculation, MathKernel sometimes remains there, still taking above 99% of the CPU. If I abort a second time (even though as far as I can tell from the Mathematica window no calculation is running), then the MathKernel process will disappear.

The most puzzling think is that Mathematica used to run fine, even with complex calculations. I have not made any changes or updates lately and it started acting this way. Now it is useless since it cannot do even simple calculations in a reasonable amount of time.

Can anyone help?

Thank you in advance!

$\endgroup$
  • $\begingroup$ Anything in your init.m file? Do $Pre, $PreRead, etc. have any definitions? $\endgroup$ – Michael E2 Jun 22 '18 at 3:36
  • $\begingroup$ Thank you for your reply. I am very new to the Mac, how do I locate this file? I tried a search in Finder but init.m must be a hidden file. I tried opening a Terminal window to search but strangely I cannot (I used to have no trouble doing that..have no clue if this is related to the Mathematic a problem, but it sounds unlikely). $\endgroup$ – Patrick Jun 22 '18 at 4:11
  • $\begingroup$ See init.m. If you execute $UserBaseDirectory, that's where you start. You should be able to cd to it in Terminal. It's probably in ~/Library/Mathematica, and you could get to it through the Finder with the Menu command Go > Library. The library directory is not indexed for SpotLight (the search index the Finder uses). It sounds like it's computing some hard integral or PDE every time you execute input. Check how long AbsoluteTiming[8 * 9] reports the multiplication takes. $\endgroup$ – Michael E2 Jun 22 '18 at 5:06
  • $\begingroup$ Thanks for your help. I did AbsoluteTiming[8*9] and it gave a time of 13 microseconds and the answer was given almost instantaneously. I was surprised so I typed it a second time and now it took almost one minute to do the calculation, but Mathematica told me that it took 1 microsecond. And after this was done, the CPU usage was still at above 99% for the MathKernel process.So yes, it looks like some other heavy calculation is started without my input. I cannot open a terminal. this is also strange,I used to have no problem $\endgroup$ – Patrick Jun 22 '18 at 6:04
  • $\begingroup$ @Patrick the front end sounds like it could also be glitchy. $\endgroup$ – b3m2a1 Jun 22 '18 at 6:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.