2
$\begingroup$

I have an output and I would like to copy and paste it into another .nb file.

enter image description here

When I copy paste using Ctrl+c and Ctrl+v. I get

enter image description here

When I copy paste using Ctrl+Shift+c and Ctrl+v. I get

enter image description here

Or When I use NumberForm I get this. I would like to plot the function after I copied it and pasted it.

enter image description here Question is: Is there a way keep the format (rational form like second image) and keep the number format like the third image when I copy paste the formula.

Here is the function,

133.59 + (582.132 i2^1.35153)/(0.428001 + i2^1.35153) + (
 6603.52 i1^0.992746 i2^1.35153)/((0.0109047 + 
    i1^0.992746) (0.428001 + i2^1.35153))

133.58951900651672` + (582.1322741801231` i2^1.3515291336147885`)/(
 0.4280007641806738` + i2^1.3515291336147885`) + (
 6603.519187497128` i1^0.9927463133595625` \
i2^1.3515291336147885`)/((0.010904677243932988` + 
    i1^0.9927463133595625`) (0.4280007641806738` + 
    i2^1.3515291336147885`))
$\endgroup$
  • $\begingroup$ When I entered your equation, I got the same results as your first pasting. Can it be that the default numbering displays are different? edit->preferences->formatting->number of digits displayed $\endgroup$ – Tom Mozdzen Jun 14 '18 at 17:10
  • $\begingroup$ I think its important to think about why you want this. There is a good reason for Mathematica to keep all of those digits. $\endgroup$ – chuy Jun 14 '18 at 17:44
  • $\begingroup$ Of course it is important to keep all digits, but I am not working on a space project and plotting function in first image and function in second image are identical. New notebook looks busy when I keep all digits. $\endgroup$ – OkkesDulgerci Jun 14 '18 at 17:50
5
$\begingroup$

What you are seeing is the effect of the option NumberMarks, which is set to True in "Input" cells and "False" in "Output" cells. If you wish to disable it in a particular "Input" cell to match an "Output" cell, do the following (there are many other ways of doing this)

  1. Select the cell
  2. Open the Option Inspector (Shift+Cntrl/Cmd+O, depending on your platform)
  3. Search for NumberMarks
  4. Uncheck the box.
$\endgroup$
1
$\begingroup$

Consider using one of the "Form" functions such as StandardForm or NumberForm

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.