1
$\begingroup$

I have the following problem. I am using Feynarts. I am running the following code: I am using QEDOnly.

topologies2 = 
CreateTopologies[0, 2 -> 2, Adjacencies -> {3}, 
ExcludeTopologies -> {Tadpoles}];
AA3 = InsertFields[
topologies2, {F[2, {1}], F[2, {2}]} -> {F[2, {1}], F[2, {2}]}, 
QEDOnly];
Paint[AA3, ColumnsXRows -> {2, 1}]

There are two diagrams, one with a photon, and one with a V particle. Why does this V particle appear? I would like to get rid of it. Thank you in advance. enter image description here

$\endgroup$
1
  • $\begingroup$ I suggest reading the manual, or try asking the author of FeynArts here: feynarts.de $\endgroup$
    – QuantumDot
    Commented Jun 14, 2018 at 3:40

1 Answer 1

3
$\begingroup$

You need to set the InsertionLevel option to {Classes}

<< FeynArts`
$FAVerbose = 0;

topologies2 = 
  CreateTopologies[0, 2 -> 2, Adjacencies -> {3}, 
   ExcludeTopologies -> {Tadpoles}];
AA3 = InsertFields[
   topologies2, {F[2, {1}], F[2, {2}]} -> {F[2, {1}], F[2, {2}]}, 
   Restrictions -> QEDOnly, InsertionLevel -> {Classes}];
Paint[AA3, ColumnsXRows -> {2, 1}];

BTW, QuantumDot is fully right about reading the manual. It is quite short, so you can finish it in less than a day. And this will remove 95% of potential questions you might have regarding the usage of FeynArts.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.