I would like to suppress the following super-annoying prompt that appears each time I exit the kernel and restart my computations:

Do you want to automatically evaluate all the initialization cells in the notebook

Which menu option do I need to tweak? (I have tried quite a few.)

  • $\begingroup$ reference.wolfram.com/language/ref/… $\endgroup$
    – ilian
    Jun 8, 2018 at 18:12
  • $\begingroup$ Can you please include a brief explanation of how to use that command? The documentation is not very helpful, and including InitializationCellWarning -> False at the top of the notebook did no avert the problem. $\endgroup$ Jun 8, 2018 at 18:21

1 Answer 1


You can choose not to have initialization cells in your notebook, by right-clicking the cell bracket and uselecting "Initialization Cell"

enter image description here

Or, if you like having initialization cells but just want them to evaluate without asking, you can evaluate

SetOptions[$FrontEnd, InitializationCellWarning -> False]

Finally, if you want to turn off the evaluation of initialization cells altogether, evaluate

SetOptions[$FrontEnd, InitializationCellEvaluation -> False]

These settings are 'sticky' and should stay set after restarting.

  • $\begingroup$ Thank you very much! $\endgroup$ Jun 8, 2018 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.