I have typed in some text input by using Alt-7 to convert everything into text, but why is text still evaluated? Or is there better way to make comments other than (* text here *), because in my text there are numbers and it is also evaluating them too?

  • 1
    $\begingroup$ What do you mean by "why is text still evaluated?" Text cells don't evaluate. $\endgroup$
    – jVincent
    Jan 7, 2013 at 15:34
  • 2
    $\begingroup$ To Alt-7 into a text cell the cell bracket to the far right needs to be selected. $\endgroup$
    – ssch
    Jan 7, 2013 at 15:51

3 Answers 3


I suspect the reason for your problem is that the cell you are typing in is not a Text cell, but an Input cell. That means it has the Evaluatable property and will be evaluated. It also means that Alt-7 won't make the text into a comment. The only way I know to put a comment in an Input cell is with (* *).

You can check this by looking at the Format > Style menu. If the Input menu-item is has a check mark, then what you trying to do with Alt-7 won't work. If that's so, you have the option of changing the cell type to Text.


If you are running Mathematica 10 or above then select any cells you want to prevent from being evaluated, then select from the main menu:

Cell -> Cell Properties -> Evaluatable

to un-tick that property.


I suspect that you did select the cell content and used Alt-7. Then the cell is still an input cell but the content is formatted as text which you can check by using the menu entry Cell -> Show Expression. That will show something like this:

  RowBox[{"1", "+", "1"}], "Text"]], "Input"] 

You should, as others have mentioned select the cell (by clicking on the cell bracket on the right) and then use Alt-7 to convert the cell to a text cell, which then won't be evaluatable with shift-return.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.