6
$\begingroup$

For a long time I've been using remote Kernels in Mathematica 10 & 11. But since some time ago I cannot connect to my remote machines on 11.3 anymore. I always get the error message

General::time: Operation LaunchKernels timed out after 10.` seconds.

I've tried different launch commands, e.g.

ssh -x -f `1` math -wstp -linkmode Connect `4` -linkname `2` -subkernel -noinit
ssh -x -f `1` math -mathlink -linkmode Connect `4` -linkname `2` -subkernel -noinit

I also switched math for wolfram and MathKernel. I tried the answer from this post, but same result. It seems that the option Parallel`Settings`$MathLinkTimeout = 100 does not work for me, I always get a timeout at 10s. On my remote machine I see the ssh connection in the log files, so ssh should not be the problem.

I didn't have this problem with previous versions, remote kernels always worked without problem. Was there some change introduced in version 11.2 or 11.3 that changed the behaviour of remote kernels? Can I set the timeout somehow ($MathLinkTimeout doesn't work)?

Thanks

$\endgroup$
  • $\begingroup$ I'd consider this a bug and I'd report it to support@wolfram.com. $\endgroup$ – user21 Apr 30 '18 at 11:51
  • $\begingroup$ Hm ok, I thought this shouldn't be normal behaviour, I just wanted to check if someone has had the same problem and maybe found a solution. $\endgroup$ – somebody Apr 30 '18 at 12:59
  • $\begingroup$ This won’t work in v11.3 anymore, they made lots of breaking changes in how links are set up $\endgroup$ – M.R. May 2 '18 at 3:07
  • $\begingroup$ Is there any other way to connect to remote kernels now? I haven't found anything in the official documentation. There they only talk about the ssh connection the way I always set it up in older versions... $\endgroup$ – somebody May 2 '18 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.