enter image description here

The above is an example in the documentation.

I run it, but it doesn't work!

What should I do?

  • 5
    $\begingroup$ This requires some initial download of data from Wolfram repository(approx 100 MB). Make sure you are on an active internet connection. $\endgroup$
    – Subho
    Apr 30, 2018 at 9:57
  • $\begingroup$ I have been connected, but there is no hint of download. How can I download data manually? $\endgroup$
    – Yonghuier
    Apr 30, 2018 at 10:32
  • 1
    $\begingroup$ Please post code rather than screenshots: easier to copy paste (and less space storing data...) $\endgroup$
    – anderstood
    Apr 30, 2018 at 16:01

1 Answer 1


Quoting from the documentation of FacialFeatures introduced in MMA 11.3:

FacialFeatures may download resources that will be stored in your local object store at $LocalBase, and that can be listed using LocalObjects[] and removed using ResourceRemove.

I couldn't get ResourceRemove to work but you can still try the following:

First, clear the data already downloaded by locating the particular resource folder under Resources inside the directory $LocalBase$. On my PC it was 6a8. It may or may not have the same name in yours. You can try to choose your resource folder by checking the time-stamp of last modification. Now, once you have located the folder, proceed to first delete it.


Then open a new session to clear the existing cache containing the resource data.

Now, re-evaluate your code. This will force a re-download from the Wolfram servers. Just ensure that you have a stable enough internet connection this time.

  • $\begingroup$ I deleted the resource data "6a8" in the folder.It's amzing.My problem have been solved.Thank you very much! $\endgroup$
    – Yonghuier
    Apr 30, 2018 at 14:01
  • $\begingroup$ @yonghui wang Happy to help! $\endgroup$
    – Subho
    Apr 30, 2018 at 14:07
  • $\begingroup$ Same problem (v11.3.0), same ressource name ("6a8"), solved by your DeleteObject command. However it seems it did not work until I removed the first "/" in the command, i.e: DeleteObject[LocalObjects["Resources/6a8"]] ... $\endgroup$
    – SquareOne
    May 11, 2018 at 22:23
  • $\begingroup$ @SquareOne Both should be fine. I don't know why putting the first slash didn't work. $\endgroup$
    – Subho
    May 12, 2018 at 3:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.