0
$\begingroup$

I have recently had need to debug a Mathematica module that I am having trouble with so I reinstalled Workbench (Vers. 2 and 3) and the Neon 4.6 version of Eclipse to tackle this. Workbench is running.

However, the icons on the Workbench toolbar are microscopic in size. Is there some way I can increase the size of the toolbar icos (ie green run button etc.) to make the program actually useable? I found that can increase the magnification of some of the text fonts, via the global preferences options, but can't figure out how to ressize the icons.

I have gone through the global preferences both in my version of Mathematica 11.3 and both versions of Workbench hoping to find a solution. Has anyone else encountered this problem?

Might this be this is an Eclipse issue that can be resolved by tweaking the Eclipse global preferences? I am unfamiliar with Eclipse.

$\endgroup$
  • 1
    $\begingroup$ Are you using Windows with a high-resolution screen? As I remember, if you right click the executable (or its shortcut) and choose Properties, there should be a checkbox for disabling high-resolution mode for this one program only. If the problem is due to HiDPI, this should fix it (at the cost of some blurriness, which is much less annoying than unusably small incons). As I remember, a recent version of Windows 10 is needed for this checkbox to be present. $\endgroup$ – Szabolcs Mar 26 '18 at 14:36
  • $\begingroup$ Thanks Szabolcs. By using properties "Compatibility" and selecting the option "Overigh high DP scaling behavior preformed by" using Application this did increase the size of the icons a bit. Sadly, not by too much but at least the program is more useable than before. $\endgroup$ – Stuart Poss Mar 28 '18 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.