12
$\begingroup$

I'm recently installing Mathematica 11.3 on my 32bit Lubuntu 18.04.

The installer installs 64bit version of Mathematica in default, so I can not run the installed version.

Below is the error output of the installer:

WARNING: Failed to install WolframScript system integration.  See
/tmp/WolframScript-InstallErrors-8297 for more details.

But the error log file listed is empty when I cat it.

Below is the output when I run mathematica:

$ mathematica
can not find /usr/local/Wolfram/Mathematica/11.3/SystemFiles/FrontEnd/Binaries/Linux/Mathematica

There is not a directory named Linux, but a directory named Linux-x86-64.

After consulting the system requirement page , I'm sure that Mathematica 11.3 can run on 32bit Linux. But they only tested it on Ubuntu 12.04–17.10, not on Ubuntu 18.04.

So my question is:

  1. Is it possible that Mathematica 11.3 can not install correctly on 32bit Lubuntu 18.04?
  2. What compatibility library do I need to correctly install the 32bit version?
  3. Is there some option in the command line that I can use to choose the 32bit instead of the default 64bit version?

My system settings are as follows:

$ uname -a 
Linux **** 4.15.0-12-generic #13-Ubuntu SMP Thu Mar 8 06:23:34 UTC 2018 i686 i686 i686 GNU/Linux

$ lsb_release -a 
LSB Version:    core-9.20170808ubuntu1-noarch:security-9.20170808ubuntu1-    noarch
Distributor ID: Ubuntu
Description:    Ubuntu Bionic Beaver (development branch)
Release:    18.04

Codename: bionic

$\endgroup$
5
  • 1
    $\begingroup$ This is one reason why I'm still on 11.2. $\endgroup$ Mar 18, 2018 at 13:45
  • $\begingroup$ @J.M. You're using a 32bit system? $\endgroup$
    – anderstood
    Mar 18, 2018 at 16:05
  • 1
    $\begingroup$ Yep, I'm using a 32-bit netbook @anders. $\endgroup$ Mar 18, 2018 at 16:42
  • $\begingroup$ @J.M.needshelp. good for you that your netbook appears to support OpenGL 2+. I'm stuck at MMA 9 since newer versions plot awfully slowly with GMA950 (due to software fallbacks). $\endgroup$
    – Ruslan
    Jul 28, 2018 at 9:26
  • 1
    $\begingroup$ This was the first question that came up when I googled "can Mathematica run on Lubuntu". For those in that situation, I just installed Mathematica 11.3 on 64-bit Lubuntu, and it installed/runs seemingly without issue. $\endgroup$
    – ktm
    Sep 29, 2018 at 16:14

1 Answer 1

13
$\begingroup$

As of version 11.3.0, support for 32-bit Linux has been discontinued.

Only 64-bit Linux is supported, and the system requirements page has now been updated to reflect that

http://www.wolfram.com/mathematica/system-requirements.html

Additionally, I sent in a bug report since I believe the installer should have refused to run on a 32-bit system in the first place.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.