2
$\begingroup$

This question already has an answer here:

After migrating to a new machine (running Mathematica 11.2 on Linux), I am experience a problem with packages in the autoload directory not loading when I launch parallel kernels.

The setup I use is as follows (I've used this before on previous Mathematica versions, where it worked perfectly.)

  • In \$UserBaseDirectory/Autoload/AddPath there is a single file init.m.
  • This file contains a single line: AppendTo[\$Path,(some directory)]

This works perfectly when launch a main kernel, adding the necessary directory to my $Path. However, the path is not added when launching parallel kernels using LaunchKernels[]. This is weird since this worked on other machines (running earlier versions). Has something changed in this new version? Alternative, is there something the system administrator (not me in this case) could have messed up when setting op Mathematica?

$\endgroup$

marked as duplicate by Szabolcs, Kuba Mar 14 '18 at 12:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ You need Autoload/AddPath/Kernel/init.m does it work now? $\endgroup$ – Kuba Mar 14 '18 at 10:55
  • $\begingroup$ I tried both, neither works. $\endgroup$ – mmeent Mar 14 '18 at 10:56
  • $\begingroup$ Either way this question is a duplicate, do you agree? So I'd mark it as such and add a comment under linked answer about problems you are experiencing. $\endgroup$ – Kuba Mar 14 '18 at 10:59
  • $\begingroup$ It is not a duplicate in the sense that the specific question is whether something changed in recent versions. A comment also really won't provide sufficient space to explain the context of the problem, I am experiencing. $\endgroup$ – mmeent Mar 14 '18 at 11:03
  • $\begingroup$ Indeed, this no longer works in 11.2. I wrote to Wolfram Support a while ago, and they confirmed the behaviour, but they have not yet responded about whether this change was intentional or a "bug". There is a duplicate of your question on this site, but I need to find it. $\endgroup$ – Szabolcs Mar 14 '18 at 12:17