3
$\begingroup$

Backslide introduced in 8.0, fixed at least in 9.0.1.


A friend of mine showed me this code sample:

RSolve[{a[n] == a[n - 5] + 1, Sequence @@ Table[a[i] == 1, {i, 5}]}, a[n], n] // Timing

It's solved by version 7 in about 40s, while in version 8 it keeps running for more than 10 minutes… is it a bug?

$\endgroup$
  • $\begingroup$ It is interesting that the same problem, with $5$ changed to $4$, is solved in less than $0.1$ seconds with MMA 8, and with $5$ changed to $7$, the solution also takes less than $0.1$ seconds (although it's trivially expressed in terms of DifferenceRoot, which is just another way of giving up). With $5$ changed to $6$, a useful solution is obtained in $6$ seconds. $\endgroup$ – whuber Dec 21 '12 at 17:58
  • $\begingroup$ This problem does not appear to affect version 10.1.0 as the system is solved in about 22 seconds on my machine. Could someone check to see if v9 is affected so that we can mark this accordingly? $\endgroup$ – Mr.Wizard Jul 29 '15 at 23:59
  • $\begingroup$ @Mr.Wizard It's already solved in v9. Well, I remember this has already been mentioned in a comment but it no longer exists, strange…BTW I think it's better to mark this as a "backslide" nowadays :) $\endgroup$ – xzczd Jul 30 '15 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.