0
$\begingroup$

I'm trying to solve this function, I've already gotten it to work when I set r but now I'm trying to do it when r remains a variable but this keeps on telling me NSolve doesn't have the methods available. I've tried using an approximation of ArcCosx and switching to Reduce and I'm not sure what I could try next?

l = 1000000/(r^2 Pi);

a = h/r;

NSolve[50000*1/l == r^2 ArcCos[1 - a] - (r - h) Sqrt[2 r h - h^2], h, Reals]
$\endgroup$
1
$\begingroup$

You could substitude h= \[Lambda] r and your equation becomes

eq = Simplify[(\[Pi] r^2)/20 == -(-h + r) Sqrt[-h^2 + 2 h r] + r^2 ArcCos[1 - h/r] /.h -> \[Lambda] r , r > 0]
(* 20 ((-1 + \[Lambda]) Sqrt[-(-2 + \[Lambda]) \[Lambda]] + 
ArcCos[1 - \[Lambda]]) == \[Pi] *)

This equation can be solved

NSolve[eq, \[Lambda], Reals]
(* {{\[Lambda] -> 0.194616}}*)
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.