3
$\begingroup$

Existing answers given in automating-esc-esc-formatting no longer work in 11.2 on windows 7 for some reason. At least I could not make them work.

It was suggested I open new question to find a solution specific for 11.2+ for windows.

I do not know when the above solutions stopped working. May be they stopped working before 11.2.

But I have tried them all under 11.2 on windows 7. None of them work. After editing the file (as administrator)

C:\Program Files\Wolfram Research\Mathematica\11.2\SystemFiles\FrontEnd
                          \TextResources\Windows\KeyEventTranslations.tr

(I made copy of the file first) and putting the code as is posted in the above linked to answers and then starting mathematica, then CTRL-] does nothing. I just hear a beep.

Mathematica graphics

I tried both solutions given above. I also tried making copy of the whole tree to $UserBaseDirectory instead of making the changes in the C:\ installation folder. It also had no effect.

The keyboard I have is plain standard logitech keyboard on USB input device. Nothing special. New keyboard and works fine. The OS is windows 7 home premium.

Since the solutions in the above answer must have worked before, why do they not work any more? and how to make Ctrl-] and ctrl-[ work in order to more easily add [[ and `]]'?

$\endgroup$
  • 1
    $\begingroup$ It works for me on Mac, I've been using it since 11.2 came out. I keep staring at your screenshot and I can't tell the difference from what I used (except that I do not have the 3rd part). If you made a copy of the file KeyEventTranslations.tr, make sure that the copy does not have the extension .tr (or better: just put it in a different folder). $\endgroup$ – Szabolcs Dec 19 '17 at 17:13
  • $\begingroup$ @Szabolcs OMG! You just answered the question. Yes, I made a copy, and the copy ofcourse had different name KeyEventTranslations - Copy.tr but for some reason, Mathematica when it comes up, instead of reading KeyEventTranslations.tr where I made my changes, it was still reading the file KeyEventTranslations - Copy.tr ! When I moved the copy to a different folder, now it works! This all makes no sense to me, but it works now. Please feel free to post this as answer. I am sure I am not the only person who will fall into this trap. $\endgroup$ – Nasser Dec 19 '17 at 17:18
  • $\begingroup$ This happened to me once many years ago. I spent a lot of time trying to figure out why things weren't working. $\endgroup$ – Szabolcs Dec 19 '17 at 17:19
  • $\begingroup$ @Szabolcs this is really a bug in Mathematica. It seems to just read the first .tr file it finds there or something. $\endgroup$ – Nasser Dec 19 '17 at 17:22
2
$\begingroup$

When you edit the file KeyEventTranslations.tr, it is a good idea to make a backup first.

If you create the backup in the same directory, make sure it doesn't have the .tr extension. Alternatively, put it in a directory outside of Mathematica's installation directory tree.

If the backup is left in the same directory and has the .tr extension, Mathematica may still read it, which can cause problems (such as the modifications you made not taking effect).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.