3
$\begingroup$

This question already has an answer here:

I had to force close my notebook because my computer was counting down to an automatic update and Mathematica kept crashing during an evaluation. I'd been working for over a week on the content, but didn't save any backups to a separate file, because I assumed there was an automatic back-up in place.

After the update I tried to reopen my notebook to be greeted with a syntax error message, saying that the notebook could only be opened in plain text. When I opened the file I got the following message:

"There was a syntax error on line 33594 in the file: Assessed Problems 1.nb. The error was: 7-bdc9-f01ad398ed45"]

}, Open ]],

Cell[CellGroupData[{

Cell[1656773, 32686, 187, 4, 28, "Input",ExpressionUUID->"f1d97f12-7677-4937-93c8-afa8c5c84eac"],

Cell[1656963, 32692, 142, 3, 32, "Output",ExpressionUUID->"fdf1f023-91b6-4629-baad-49bc0bec11c8"]""

How can I fix this? Can anyone help me? I looked at previous questions on the stack exchange network and tried to copy the work to a new notebook and then delete some code and then reformat the cells back to the traditional output, but this isn't working.

I am running Mathematica version 11.2.

$\endgroup$

marked as duplicate by Alexey Popkov, Henrik Schumacher, Emilio Pisanty, m_goldberg, Coolwater Jan 13 '18 at 16:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ Unless it is very long you can open it in a text editor, got through all Cell[BoxData[...], ....], copy them, paste to a new notebook. $\endgroup$ – Kuba Dec 13 '17 at 22:07
  • $\begingroup$ I forget when I had to do this, but maybe it was in such a situation: Copy your file. From within Mathematica, do menu File > Open...; select your file (or the copy) AND click on the Options button. Select "Parse and load entire file" (or something like that). Then open and see whether it salvages anything. $\endgroup$ – Michael E2 Dec 13 '17 at 23:07
  • $\begingroup$ Can you post your full notebook? $\endgroup$ – M.R. Dec 14 '17 at 0:00
  • 1
    $\begingroup$ @M.R. Your joking, right? You did notice the error occurred on line 33594? The notebook is too big to post here. Maybe it can be posted on Dropbox or a similar sharing site. $\endgroup$ – m_goldberg Dec 14 '17 at 0:27
  • 4
    $\begingroup$ try this $\text{Needs["AuthorTools`"] ; NotebookRestore[] }$ see how-to-restore-corrupted-files $\endgroup$ – Nasser Dec 14 '17 at 1:14
1
$\begingroup$

Thank you all for your help. I ended up taking Nasser's advice and used the notebook restore and got my notebook back minus six lines of corrupted code. I was stressing about it all night so I'm very happy that I got the notebook back. I'll take this as a lesson about saving back up copies of my notebooks.

$\endgroup$
  • 2
    $\begingroup$ Please elaborate on the steps you've taken so others can follow in future. $\endgroup$ – Kuba Dec 14 '17 at 11:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.