Just as what is described in the title, the notebook behaves as if it were originally designed to not have the autocompletion functionality at all. Neither Ctrl+K nor F2 works. Furthermore, reinstalling Mathematica does not help, either.

What measures could be taken that possibly help to recover the autocompletion functionality? I suspect that some items in "Option Inspector" might be responsible but I can not find them.

It seems that quite a few people encounter this problem recently.

But, for now, the "$UserBaseDirectory deletion / renaming methods" cannot thoroughly settle this issue, can they?

  • $\begingroup$ Hard to say without more details. Provide the version of MMA and the system running it. Does this happen in a fresh-started kernel in a new empty notebook? Try clean-starting Mathematica, maybe there's some lingering user settings not being removed upon reinstall. I experience that Dynamic functionality sometimes interferes with autocomplete, but that shouldn't be the case in a fresh notebook and kernel. $\endgroup$
    – LLlAMnYP
    Commented Nov 24, 2017 at 13:05
  • $\begingroup$ @LLlAMnYP Windows 10 + MMA 11.2. It happens even in a freshly started one. $\endgroup$ Commented Nov 24, 2017 at 13:24
  • $\begingroup$ I'm not running this particular combination, so I can't check for myself. Most likely this is something very localized to your machine, in which case this is off-topic here and should be addressed to Wolfram support. $\endgroup$
    – LLlAMnYP
    Commented Nov 24, 2017 at 13:45
  • 2
    $\begingroup$ @LLlAMnYP I think I find the problem source. It is an unofficial package (github.com/rolfmertig/Shortcuts). It is very strange that the package causes this problem just recently. $\endgroup$ Commented Nov 24, 2017 at 15:20
  • $\begingroup$ @Kuba So far I have no definite conclusion on the origin. And I put forward my suspicion, neither necessary nor sufficient conditions. Unfortunately, every now and then I suffer from the annoying symptom, even with the "$UserBaseDirectory deletion therapy". $\endgroup$ Commented Nov 28, 2017 at 12:40

2 Answers 2



should resolve the issue at this point.

  • $\begingroup$ Yes that worked for me! Clean Start didn't help for me. $\endgroup$
    – Lou
    Commented Nov 28, 2017 at 15:47
  • 1
    $\begingroup$ It seems that I can use Shortcuts again. Could you please explain what happens? $\endgroup$ Commented Nov 29, 2017 at 5:46
  • $\begingroup$ Not sure, just saw the answer on the other forum. $\endgroup$
    – ktm
    Commented Nov 29, 2017 at 13:43

I had exactly the same problem today (I have Mathematica 11.2 and Windows 10): the autocomplete suddenly disappeared and neither Ctrl+K or F2 worked.

I don't have any additional packages installed; only the basic Mathematica. I tried clean-starting and that didn't work.

I managed to get autocomplete to work again by deleting the $UserBaseDirectory and restarting:

See also

I hope this helps!

It appears that Shortcuts` package can be involved but it is not clear how, see update in:


so before you delete whole $UserBaseDirectory you can try:

Needs @ "Shortcuts`"
  • $\begingroup$ So you didn't have Shortcuts` package installed? $\endgroup$
    – Kuba
    Commented Nov 28, 2017 at 12:26
  • $\begingroup$ I have the same problem since this morning. I don't have the shortcuts package installed. $\endgroup$
    – Lou
    Commented Nov 28, 2017 at 15:28
  • $\begingroup$ I don't think I had `Shortcuts`` installed (I am new to Mathematica and only installed from the iso nothing more). $\endgroup$ Commented Nov 29, 2017 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.