3
$\begingroup$

We know that Mathematic doesn't natively support Windows Authentication connect. But as we can see in this post, the problem can be easily solved when your Mathematica is in Windows version (I have just made it).

The company that I work is now changing to Windows Authentication, and the problem is that I use both Mac and Windows.

Question:

There is someway that I could connect into SQL Server database using Windows Authentication from my Mac Mathematica? So I could pass my Windows Domain/User and Password together with the jDBC connections string?

PS: I don't want to use Windows version of Mathematica in my Mac by Parallels, this will be my last shot.

$\endgroup$
5
  • $\begingroup$ Have you tried updating the jTDS driver? Mathematica 9 includes jTBS 1.2.5 and the newest version is 1.3.0. Not sure if the newest version will include Windows Authentication support. $\endgroup$
    – kale
    Commented Dec 9, 2012 at 1:54
  • $\begingroup$ Reading the Single Sign On README.SSO file included with the latest jTDS release, the Windows Authentication relies on the ntlmauth.dll to glean system information from the PC (Domain, username, etc.) and allows access to the database. So with the jTDS implementation, Mac SSO is not supported (I've tried the newest version here at home VNC'd in to the office). Possibly another 3rd party ODBC solution would include this support. $\endgroup$
    – kale
    Commented Dec 9, 2012 at 21:25
  • $\begingroup$ But in the FAQ of jTDS I founded this, I'll test tomorrow: "Domain: Specifies the Windows domain to authenticate in. If present and the user name and password are provided, jTDS uses Windows (NTLM) authentication instead of the usual SQL Server authentication (i.e. the user and password provided are the domain user and password). This allows non-Windows clients to log in to servers which are only configured to accept Windows authentication." $\endgroup$
    – Murta
    Commented Dec 10, 2012 at 2:03
  • $\begingroup$ Yeah, I see that now. Just tried it but am still getting a warning about an untrusted domain. Might be because I'm on a VNC connection. Add the ";domain=*whatever*;user=*username*" and see if that works tomorrow. If so, I'll delete my useless comments. $\endgroup$
    – kale
    Commented Dec 10, 2012 at 2:38
  • $\begingroup$ I don't know how to install/update to the jTDS 3.0 version. I'm waiting Wolfram Enterprise Support to see with they can help me. If I get something I'll put here. tks $\endgroup$
    – Murta
    Commented Dec 11, 2012 at 0:00

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.