3
$\begingroup$

Bug is present in version 11.2.0


This fragment used to generate a HTML code for a webpage in which the Hyperlink showed up as an active link when viewed in a web browser. Now, with Mathematica 11.2 the link is no longer active. Have I overlooked something?

Export["~/Desktop/test",
 Notebook[{
   Cell["testing", "Section"],
   Cell[BoxData[ToBoxes[
  Hyperlink[
   "Back to Interesting Science", "http://www.bgc-jena.mpg.de"]]]]
   }], "HTML"]
$\endgroup$
  • $\begingroup$ I confirm that the link in the HTML file exported with version 11.2.0 on Windows 7 x64 doesn't work . With version 8.0.4 it does work on the same machine. Obviously it is a bug, so I add the tag. $\endgroup$ – Alexey Popkov Oct 27 '17 at 17:30
  • $\begingroup$ Related Wolfram Community thread: "HTML Export Error in 11.2?" $\endgroup$ – Alexey Popkov Nov 12 '17 at 5:39
6
$\begingroup$

Here is a workaround which works for me. On version 11.2, windows 7

SetDirectory[NotebookDirectory[]];
If[Not[DirectoryQ["test"]],
   CreateDirectory["test"]
];

Export[
 "test", (*saved in this folder below current folder*)
 Notebook[{
 Cell["testing","Section"],
   Cell[BoxData[ButtonBox[RowBox[{"Back to Interesting Science"}],
       BaseStyle->"Hyperlink",
       ButtonData->{"http://www.bgc-jena.mpg.de", None}]]]
   }],
"HTML"]

And now the genenerated HTML works and link is active.

Mathematica graphics

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.