7
$\begingroup$

MacOS 10.13
Mathematica 11.2.0.0
This is part of an assignment - my Semanticimport fails with all files though. the error:
Dataset ExtractRawData::dataextr: Data extraction failed.

The code is in the screenshot attached - all semanticImports fail, not only this specific csv.

enter image description here

If I do a simpler import like:

dataSemantic = Import[("/Users/dave/Dropbox/Uni/appliedempirical/DATA A0 2.csv")];
dataA0 = Dataset@dataSemantic;

it all works out. Can somebody help me with this?

EDIT:
I have now tried to use semanticImportString and drag and dropped the file. it seems to import it, but after querying I still get an error:

SemanticImportString[Missing["PartInvalid", "age"], 

Missing["KeyAbsent", "age"]]

$\endgroup$
  • $\begingroup$ Try Import[file, "Dataset"]. Are you able to upload your files? $\endgroup$ – GenericAccountName Oct 17 '17 at 4:21
  • 1
    $\begingroup$ I have issues to with SemanticImport on Mac OS 10.13. Even examples from the Documentation simply return $Failed. I added the Bugs tag $\endgroup$ – Sascha Nov 7 '17 at 8:50
  • $\begingroup$ Same here, SemanticImport fails with every try. $\endgroup$ – FractalDoctor Nov 29 '17 at 11:30
  • $\begingroup$ Having the exact same issue Mac OS 10.13.1 all examples of SemanticImportString from the Documentation return $Failed $\endgroup$ – ulysseus Nov 29 '17 at 21:56
5
$\begingroup$

This is a bug specific to macOS 10.13 ("High Sierra").

It is caused by incompatibility between the operating system and the golang runtime library used by the binary component of SemanticImport (and of course SemanticImportString).

A fix for this issue has been released via paclet update. The update should be installed automatically when SemanticImport is first used in a fresh session, and the following code may be run to obtain the update manually

PacletSiteUpdate /@ PacletSites[];
PacletUpdate["SemanticImport"]

after which the paclet version should be 0.0.457.

$\endgroup$

protected by Kuba Nov 29 '17 at 23:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.