I got this all the time after updating to 9.0 (OS 10.8.2):

"Internal self-test error" message

That's Clipboard|c|3015 for the benefit of anyone searching.

The error went away with 9.0.1, but a version has reappeared (multiple times at each launch) since updating my OS (to 10.9):

enter image description here

That's SpanBox|c|2178 for the benefit of anyone searching.

What does an "Internal self-test error" mean?

  • 5
    $\begingroup$ I've reinstalled multiple times, rebooted, etc.. I've also contacted Wolfram, both through the reporting mechanism in the "click here" link, and directly through "Premium" support. $\endgroup$ – orome Dec 4 '12 at 17:17
  • 2
    $\begingroup$ This isn't specific to version 9. I get them sometimes on version 8. I assume it's a trapped bug or failed assertion, from which Mathematica is able to (gracefully or not) recover, unlike the crashes and freezes, from which it can't. $\endgroup$ – cormullion Dec 4 '12 at 18:11
  • 2
    $\begingroup$ I have also been getting these things all the time, doing all sorts of random things. Especially when browsing the Documentation Center. $\endgroup$ – Eli Lansey Dec 4 '12 at 18:12
  • $\begingroup$ @cormullion: I get this in all kinds of circumstances. Even things like just typing Cmd+Shift+F. $\endgroup$ – orome Dec 4 '12 at 18:14
  • 1
    $\begingroup$ FWIW, I have gotten Kernels|c|6568 $\endgroup$ – Eli Lansey Dec 4 '12 at 18:50

I think the comment of @cormullion is on target. The developers put in such internal tests to check for conditions that theoretically should not happen. If you report them, supposedly they try to track them down and fix them. It helps if you can create a notebook that reproduces the error. You see a lot more of them in beta testing. This one in particular (Clipboard|c|3015) has been persistent. I've been unable to create conditions that reliably reproduce it. If no one else can, then it might be with us for a while. I still report it now and then (squeaky wheel). The message itself is funny: "find out if this problem is known...." I've never found out.

I doubt it's a third-party issue, unless the third party is the OS.


Given the specific error you cite (badPasteboardSyncErr) my initial thought would be that perhaps you have some sort of 3rd party clipboard management utility that isn't playing nicely with Mathematica.

  • 8
    $\begingroup$ That's what "support" said too. But I don't have any such utilities (that I know of) and in any case, it's a bit weird that Mathematica (my most expensive app) should be the only one that's so sensitive. $\endgroup$ – orome Dec 9 '12 at 15:32

I got the same error one day and after I restarted Mathematica, I became unable to open a notebook.

I tried this and the problem was fixed.

How do I fix common problems by resetting Mathematica to its default configuration?"


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.