I get a Missing[NotAvailable] error message when trying to access Social Media Data using SocialMediaData["Facebook", "Friends"] in Mathematica 9 on Linux. Now, I don't know how to find the source of the error. I don't have the same error for twitter. Is there a way to get verbose error information?

  • $\begingroup$ Is this the trial version? If that's the case the problem lies in restrictions placed on ExportString in this version. Only thing you can do is obtaining a student/home-use/full license. $\endgroup$ – Sjoerd C. de Vries Dec 4 '12 at 12:29
  • $\begingroup$ It's a full Mathematica for sites license. $\endgroup$ – Igor Dec 4 '12 at 13:07
  • 1
    $\begingroup$ I also have a full Mathematica license and I get the same error message. I wonder if it has something to do with privacy settings in Facebook. $\endgroup$ – Cassini Dec 4 '12 at 14:24
  • $\begingroup$ What about other properties like SocialMediaData["Facebook","UserData"]? If other also gave you the same Missing error, then it might be your access code is incorrectly copied. $\endgroup$ – halmir Dec 4 '12 at 22:29
  • 1
    $\begingroup$ A quick check of Mathematica 9.0.1 seems to show that the problems with SocialMediaData (at least for Facebook) have been fixed. $\endgroup$ – Cassini Jan 31 '13 at 21:16

It works for me with sites license, here is the permission setting on Facebook.

Facebook setting

|improve this answer|||||
  • $\begingroup$ My privacy settings look pretty much the same. $\endgroup$ – Igor Dec 5 '12 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.