0
$\begingroup$

I have a lot of code for importing csv data from a research project. Everything fine with Mathematica 11.1.1. Now I have 11.2 and it seems as if UTF8 import ist buggy. I use the following simple code to get the data in:

file = SystemDialogInput["FileOpen"]

and

data = Import[file, "CSV", CharacterEncoding -> "UTF8"]

with 11.2 I get a lot of error messages (see screenshot) and the German Umlauts are all corrupted. No problems with 11.1.1. Can anyone help or confirm. enter image description here

Example Data can be found here: example

$\endgroup$
  • 1
    $\begingroup$ Can you share a file which we could possible investigate this using? $\endgroup$ – user6014 Sep 25 '17 at 20:28
  • $\begingroup$ Sorry and thank you for the comment, I forgot to place the download link in the text.... just done! $\endgroup$ – mgamer Sep 25 '17 at 20:33
  • $\begingroup$ I am not debating whether there was an issue or not, but I do see the same error messages in 11.1 and 11.2. $\endgroup$ – user6014 Sep 25 '17 at 20:36
  • $\begingroup$ In any event, if you think there is an issue just report it to support@wolfram.com and they can provide more info, etc... $\endgroup$ – user6014 Sep 25 '17 at 23:14
  • $\begingroup$ I get the same with version 8.0.4 on Windows 7 x64. But when I simply do Import["Example.csv"] it is imported without errors. The obvious conclusion is that the file is NOT UTF8-encoded. $\endgroup$ – Alexey Popkov Sep 26 '17 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.